Help me Obe Wan Kenobe - Win wont install

Hi guys

Been a while since I’ve been around so a big hello to my old drinking buddies! :wink:

Now unfortunately I’m stumped on a pc prob and was hoping you could help.

Summary: Windows wont install as it cant detect the new sata drive.

Detail: Windows setup appears to freeze at “Setup is starting Windows” text screen. However, after about 20 minutes it displays a message about pressing enter if you want to install windows or something else to repair it. When I select to install windows it returns with the message that no hard drives were detected.

mobo - GA-M57SLI-S4
cpu - amd 64 2.2ghz LE-1600 socket am2
ram - 2 gig kingston
hd - samsung hd753LJ
graphics card - 7600GT
Psu - Arctic 500W
DVD burner - LG

Heres what I’ve tried so far…
xp home sp2 install cd
xp pro sp2 install cd
xp home sp2 cd with slipstreamed motherboard sata drivers

All of above with f6 and a floppy with sata drivers
All of above with f5 and acpi uniprocessor
all of above with f7

Flash bios to latest version
changed cables
changed sockets cables connect to on mobo.
removed all but 1 stick of ram

From a bootable Cd with diagnostic utils on it - Ultimate boot cd
Ran memtest86 for 15 hours and 15 passes - pass
Ran cpu burn-in for 10 hours - pass
Tried to run the samsung hard drive diagnostic but it could not find the hard drive despite appearing to install its own sata drivers during the start up of the application

It may be worth noting that I had originally set the system up with a maxtor sata hard drive a few months ago. However the pc had never been burned in and on the few occasions it was turned on it BSoD forcing a format and reinstall. Then it died complaining of corrupt windows system folders and refused to start up again. So I assumed it was the hard drive at fault and replaced it with the Samsung drive.

Now for the weird bit. My own computer!
I installed the original maxtor drive into my rig to back up the data and My first sata soket on my mobo failed and then the second followed. Then windows (on the ide main drive) kept freezing within a few mins of booting. I started getting bios warnings that something was trying to change the bios (either virus or windows crashing)
I ran cpu burn-in and the system kept dying within a few minutes.
Then windows would not boot at all for several hours.
Now several hours later I’m in windows again - but despite installing the sata drivers again on my system there is no sign of the hard drives.

I’m not so bothered about my own system at the moment as it is up and running and I also have a laptop if needs be. Its the other system for my bro that I urgently need help on.

So a big thanks for any suggestions I can try out.

When you added the Sata Drive did you change the bios to make sure it still booted the Pata Drive 1st - or did you potentially boot the Sata one.

If not…

  1. You may have allowed HD to boot using Sata Drivers not compatible with Your own… potentially causing hardware damage.

  2. You may have allowed an infected drive to infect your Pata drive.

Normally this is when I find USB drive Caddies Usefull though I don’t have a Sata one :frowning: but my normal routine is to caddie a drive and look at it on another system, never allowing it to be a boot drive… then Virus scan it / recover critical data / Nuke it / reformat / Fdisk then stick it back in the original system & re-install.

Viruses being funny things maybe have got into the Bootsector/filepartition table/blah blah blah or somewhere worse so it needs nuking completely.

In the bios have you got the SATA controller set to IDE or AHCI , I think IDE is the preferred setting .

cheers for the info guys

Bros rig
have managed to install windows on another sata drive - but still cant detect samsung 750Gb drive
So it looks like a dud samsung. Or there is something preventing the system finding large hard drives? The version of the bios is meant to support 1Tb drives tho’.

My rig
still intermittently freezes and then refuses to boot for several hours at a time with the boot sequence giving me an audible “cpu failed boot test” warning
Sata slots dont work despite updating sata drivers.

PMM - I assume you are talking about my machine not my bros. In which case…
My machine
boot priority was pre-set to floppy-pata-cd or floppy-cd-pata depending on what I was doing.
I’ve never booted from sata drives.
Bros Machine
Only one sata drive installed at a time (until this afternoon when I managed to install windows on the maxtor and was still unable to see the samsung)

So even with the boot priority set to pata and it never leaving the case - could it have changed the boot priority and fried my mobo?
Would that have fried just my mobo or anything else?

With regards to viruses - I’ve used avg to scan my working pata (current defs and heuristics) with no sign of problems.

Mortlake - cheers for the info but I’m not sure which rig you are referring to.
If mine
then its the via chipset that governs the sata slots labeled primary and secondary.
With the other 2 sata slots sata1 and sata2 being governed by the promise controller and meant to be used for Raid setups only.
To that end the promise controller is disabled in bios and the other sata reference in my bios being “On-chip Sata Bootrom” also disabled as instructed.

In my Bros Rig
There are the following settings
On-chip ide channel = enabled
NV Serial-ATA Controller = All enabled
Serial-ATA Raid Config = Disabled

The latter if enabled would change specified slots to raid only

But there doesnt seem to be anything like “AHCI” and I cant find a way to detect the samsung HD

I’m therefore assuming the samsung to be dead.
(I also ran a samsung diagnostic which couldnt find the samsung
and I ran a maxtor diagnostic which could only find the maxtor and the ‘long’ test said the maxtor is fine)

However that leaves my bros pc with the same hardware that repeatedly caused BSOD’s and corrupt windows system - unrecoverable and requiring reformat/reinstall

Its probably worth noting since we are getting into it what my (rather ancient) rig is
CPU - AMD Athlon 64 3000+
mobo - Asus K8v se delux - socket 754
ram - 1Gb Kingston value
graphics - point of view 7600GT (AGP)
PSU - 400W JeanTech
HD - 1 x pata spinpoint 250Gb + 2 x sata spinpoint 250Gb + 1 x WD 500Gb external

So what now?
My rig
Fried mobo/cpu?

Bros rig
Run the Mersenne Prime Test for about a week to see what happens?


So even with the boot priority set to pata and it never leaving the case - could it have changed the boot priority and fried my mobo?

Yes unless you changed it in Bios 1st - That is what I was trying to convey, If you had put the Sata drive in alongside your Pata drive the Bios would see it as an extra drive and include it in the list of bootable devices but on occasions the addition of a drive can change the list order and you need to re-sync it before it gets past the Bios stage.

oh pants!

guess thats what happened then

so these warnings that I’m getting when the system tries to boot that the cpu has failed is actually potentially erroneous and can also be attributable to the mobo?

Yes - but it may have effected the CPU as well !!

If that occurred its not just the Sata Drivers but yours is a VIA Chipset and his is a Nforce board thus different chipset drivers as well.

So it would be hard to say what occurred when it tried to invoke Nvidia Drivers on your VIA chipset.

ok great - thanks for the info mate.

I guess I’ll be posting a thread on what gear to get for about £200 very soon :wink: