Samba Sharing Modes

Is there a way in Samba I can have a combo of windows type sharing and logging on sharing?

I’ve edited the /etc/samba/smb.conf and changed the following to allow the Windows style sharing

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/Samba-HOWTO-Collection/ServerType.html
# in the samba-doc package for details.
   security = share

I want to share my music and video throughout the house with a share capability but would like to access my documents via a user based server so only I can access and change my documents like work and the like.

I cant really see anything that helps in the file:///usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html file:(

Use security=share

In the “documents” share details use the structure

Valid users = fred, billy

This will force login and password for this share only, and allow access to fred and billy.



Muchos Gracias Mojo :slight_smile:

Works a treat

I know this is dug up from the past but I’m stuck.

Re installed Ubuntu and setting up samaba again seemed simple.

I’ve tried doing this again but appears something may have changed because I cant access it.

I have this:-

path = /home/chris/foldingathome
available = yes
browsable = yes
public = yes
writable = no

path = /home/chris/Documents
valid users = chris
available = yes
browsable = yes
public = yes
writable = yes

[Portable HD]
path = "/media/Portable HD"
Valid users = chris
available = yes
browsable = yes
public = yes
writable = yes

But when I try and get into the protected folders it forces me to use guest. I cant set the username up. I have a username setup but the box in windows appears saying LINUXRIG\Guest and asks for password.

Kinda of at a loss as testparm seems fine.

If I understand what you’re saying then you need to set up chris as a samba user:

smbpasswd -a chris

Enter password and restart samba.

Methinks Mulda has it. But if not, ensure your samba.conf specifies security=share. And it would be wise to disable the guest account in the same file for security reasons.

I’d already added chris as a Samba user :shrug:
Samba.conf does have it as share.

This is what happens trying to access from Windows

it wont let me specify a username.

I can access downloads and foldingathome folders fine. They’re shared.
It does the same whether I try and get or linuxrig.:frowning:

My smbusers file has

chris = "network username"

but cant remember if it should be chris = chris

Can you post your whole samba config file please Drezha? And which version of Winders are we dealing with, XP?

There’s a GUI tool for Ubuntu Samba as well (gsambad from memory??) which may give you a clue.

This may sound really stupid, but check your firewall. Disable Windows or any additional firewalls and give it a shot. This is the same problem I had with my NAS and it just screams of the same reason.

Celtic, I’d tried that. Disabling the firewall and adding the entire local network range of IP’s to my trusted zone (using Zonealarm…trusted netowrk at medium and internet at high)

Yeah, it’s XP. (Usong the funky MS Zune theme)

Config attached as text doc.

Never heard of gsambad but :google: helped :thumbsup:
Will install and try. Only one I knew about was SWAT.

OK buddy please tell me you have only one network interface and it is called ‘eth0’? And what is written to the logfiles in /var/log/samba/log.?? for the server and client when you try to mount the problem share? How does this differ from the log for accessing the shares you can use? What about file permissions on the directories being shared? Tried deleting samba user “chris” and reinstating?

Yeah only one NIC and thats eth0.

I’ll stick with taking the password off I think. It was only there to stop flatmates deleting things. Hopefully I’ll be ok. As they don’t know they can add to those folders…

You have public = yes in the protected shares.

Even removing that didn’t help I’m afraid Kevin :frowning:

Drezha if you want to solve rather than bodge this then the contents of /var/log/samba/log.?? will be your friend.

Here’s the two log files in question I believe.

I cant make head nor tail of them really.

What happens if you try from a command prompt:

net use \\foldingathome /user:chris

does that work at all?

That tells me to start with the password is wrong so I enter it and it then tells me the network path doesn’t exist.