screen blackouts


No ATI currently in here. And with the new PSU put in yesterday, I had my 1st screen wobbly just as I reach this page! So we can eliminate power I think…

Given that I had one stress test error, even if it wasn’t reproducible, that suggests the gfx issue might be a side effect of something else, rather than the problem in itself. I’m wondering if a clean install would be any help but I can’t be arsed with a full reinstall, plus even a test install I’ll need to run for weeks since this is so unpredictable.

Think I’ll double check mobo drivers, re-flash the bios and downclock the ram a bit and see if that helps. The ram is in its spec, but above that officially supported by Intel I think.

Edit: a “load failsafe defaults” seems to have fixed some funnines I saw in the bios earlier, so I wont re-flash. Lowered ram speed will see if that helps.


And another one. I think that’s pretty much everything I can rule out ruled out. I even turned up the case fans which didn’t seem to have much impact on CPU temps at least. The only thing I could but haven’t done is a clean OS install for obvious reasons. I have already done a sfc scan of Windows files just in case.

Maybe I’ll just endure it until Ivy Bridge is out then do another complete system replacement…


I’m assuming all this is happening on the same motherboard? Assuming all else is OK, what about the mobo or cpu?


CPU isn’t overclocked beyond built in turbo modes. I’m not impressed by the mobo but there’s no sign anything specific is wrong either. A wobbly every other week isn’t something I can replicate at will to narrow it down further. Apart from the one occasion I did have a stability test fail (CPU-mobo-ram possible culprits), they usually happily run until I’m beyond bored. This is a once in a long time issue and without a way to replicate it, it just isn’t fun to hunt down. A new mobo is effectively a new build anyway.


Out of curiosity (and laziness reading all this thread), have you tried a different OS to isolate if the problem is hardware or software? I use Knoppix for that sort of thing. If I run Knoppix off the CD Drive and all works normally, then it’s software. Otherwise the problem should persist if it’s hardware.


The biggest problem to testing if it’s software or OS related is the rarity of these events. I can’t cause them to happen at will, and it can be a couple weeks without incident before I get one. I’m not up to running an alternate OS for that long.

Side note, I found my PC had rebooted when I got home. I don’t know if that might be another crash causing a reboot, or if there was a power failure since I don’t have any other records to go against. Or do I? I wonder if my router has an uptime counter… yup, it does, and 95 days. So it is unlikely for me to have had a power glitch. It was probably another instability manifestation…


Reading through the thread again, I notice there is no mention of renewing CPU/Heat-sink thermal compound to eliminate localised hot spots not showing up on the on die thermal sensor - easy and cheap to do


That falls into the “could give it a try” category, if I can find my paste. I find it highly unlikely though. Current temps are far below that when I had the stock heatsink on, and I don’t think the thermal gradient would cause localised hotspots of a sufficient magnitude to cause heat related problems.

One thing I haven’t tried is simply not running the CPU under load. I’ve crunched on it pretty much continuously… now I’m not saying I wont crunch at all on it, but I might try stopping it while I’m home. Crashes do seem more likely to happen when I’m using the computer.


Have you tested your memory yet? Random weird stuff can happen when memory is faulting intermittently. I suggest running MEMTEST86 for at least 10 cycles. I’ve found intermittent problems that way. The trick is to let it cycle repeatedly, hence the 10 cycle minimum. With a problem like yours you might opt for 20 cycles (could take a while… ). I had one friend’s computer I fixed which only failed on cycle 8 out of 10. The correction was the CAS-RAS timing going from 1T to 2T. I just made a similar adjustment to my gaming system to correct a problem where video would lag horribly in one game only, and only for a few minutes before cleaning itself up, plus my wireless mouse would lock up. Intermittent memory failures can be hard to catch.


I guess I could try a more extreme memtest. I did 2 hours of it before for 3 passes. That’ll be one for overnight I think!


Bonus points go to Egad! I had a single error on pass 10, and no more listed after 18 passes over 20 hours. But the error counter says 4? Regardless, I guess there’s the fault, and now I just have to fix it. Guess memory timings are the first port of call but I’m not sure what I can tweak there since I’m running at slack timings already and the module is higher rated. Now the question is if a module is borderline dodgy, or is there some inherent compatibility issue…


Ooh! what did I win? :smiley:

Do you have some other memory lying around you could swap in? Memory is dirt cheap nowadays. If you have something you could swap in, you can run the same set of tests again to verify it’s the memory and not the mobo.


I’m trying a different setting. It doesn’t seem to alter any timings I have direct access to, but there are “standard”, “turbo” and “extreme” modes. Turbo is the default, so I’ve backed it down to standard and increased the speed again to the ram’s nominal rating. Almost 4 hours in and 4 passes done, no errors so far.

The only other DDR3 I have at home is 2x1GB and that isn’t going to be fun even for diagnosis!


14 passes in 14 hours clear so far… but the question now is how long do I need to run for? While I got an error last time in 10 passes, given the rarity of the error anyway I have no idea how frequent they may happen, thus how long I need to test for confidence.

At least I’m now getting my value out of my laptop. I think I’ve used it at home this weekend so far more than I’ve used it at home total ever before now.


Back on main computer for now as I needed some files off it. While I’m here…

The error!

The mysterious “performance enhance” option. Defaults to Turbo.

Default timings with XMP disabled. None of the values change with Performance Enhance setting.

Timings with XMP enabled and Performance Enhance set to Standard.

19 passes in 19 hours ok until I rebooted.

Going to use the computer for now. Might give it some more overnight memtest passes.


That’s a good question, and I don’t know a good answer. Considering the memtest pushes your memory more than normal everyday use does, the likelihood of finding an error within a (relatively) short period of time is much more probable. I would run for 24 hours, just to be thorough, and if no errors in that time, consider the problem solved.


And there goes another screen glitch. I didn’t do more memtesting after the above so I guess I should do it for longer. Further to that, there’s also the possibility there are two unrelated problems…

Actually, technically speaking I haven’t memtested my current running configuration. I found a nasty feature of my mobo bios. If I turn on XMP, it overclocks the CPU to 3.8 GHz with a bump in core voltage. I only spotted this as my CPU temps seemed above normal. So I’ve been running with XMP disabled, so CPU at 3.5 GHz 4 cores loaded with turbo, and mem at reduced timings. Never easy is it…


Dunp the i7 and give that 1055T another blast… you know it makes sense!!!


Got another error, sample place as last time. This time on pass 11. Suppose it could be duff ram? I might try swapping slots, and see if the error follows it.

X6… I really don’t want to move all my programs, settings etc. unless I really need to.

Edit: fork it, just seen how much ram has fallen since I got mine. Just ordered another 2x4GB. That’ll either fix it or confirm it isn’t the ram… I could use more ram either way as my X6 cruncher has been ram starved for too long with only 2GB total spread between the OS and 6 cores.


Since the same test always fails, that can speed up memtest fault finding somewhat. I just done the module swap, and the same address is failing, so suggesting it isn’t the modules? What does that mean? Is it the CPU? Or the mobo? Or some timing somewhere still needing a little tinkering? I tried limiting the test range too, but that didn’t seem to help further. Possibly the pattern causing it has longer pre-requisites.

As an observation when switching between normal and XMP profiles the Vtt goes from 1.05v to 1.2v. I’m currently not running XMP at all, but wonder if a slight bump on that would help?

My first stop is I have grabbed the timings from the XMP profile and entered them manually but at 1333 not 1600 MHz and will see if that helps. If not then it’s onto the voltage above.

Still getting the other ram anyway just for another set of variables to play with…