Win2003 login remotely to FC4 via VNC

I know that there are heaps threads about this topics , but this what I did without any success

This is what I did on FC4 I am logging as root (I know the security implication)
First:
[root@localhost ~]# rpm -q --info vnc-server

Name        : vnc-server                   Relocations: (not relocatable)
Version     : 4.1.1                             Vendor: Red Hat, Inc.
Release     : 10                            Build Date: Wed 27 Apr 2005 10:44:11 AM GST
Install Date: Wed 15 Feb 2006 11:53:50 PM GST      Build Host: decompose.build.redhat.com
Group       : User Interface/X              Source RPM: vnc-4.1.1-10.src.rpm
Size        : 3054396                          License: GPL
Signature   : DSA/SHA1, Fri 20 May 2005 10:28:29 PM GST, Key ID b44269d04f2a6fd2Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.realvnc.com
Summary     : A VNC server.
Description :
The VNC system allows you to access the same desktop from a wide
variety of platforms. This package is a VNC server, allowing others to
access the desktop on your machine.

Second:
The gedit /etc/sysconfig/vncserver


# The VNCSERVERS variable is a list of display:user pairs.
# Uncomment the lines below to start a VNC server on display :2
# as my 'myusername' (adjust this to your own). You will also
# need to set a VNC password; run 'man vncpasswd' to see how
# to do that.
# DO NOT RUN THIS SERVICE if your local area network is
# untrusted! For a secure way of using VNC, see
# <URL:http://www.uk.research.att.com/vnc/sshvnc.html>.
#zillah uncomment VNCSERVERS="2:myusername"

[B]VNCSERVERS="2:root"[/B]
#zillah uncomment VNCSERVERARGS[2]="-geometry 800x600"
[B]VNCSERVERARGS[2]="-geometry 800x600"[/B]

Third:
[root@localhost ~]# vncpasswd root
Password:
Verify:

Fourth:
[root@localhost ~]# vncserver
New ‘localhost.localdomain:2 (root)’ desktop is localhost.localdomain:2
Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/localhost.localdomain:2.log

Is the command “vncserver” same as “service vncserver start” ?

[root@localhost ~]# service vncserver start
Starting VNC server: 2:root A VNC server is already running as :2

Then from windows, you just need to connect using the viewer, and type
[hostname]:[screennum] in the connect box, and type in the correct

I could not find the option that he(in the quote above) was pointing , could you please look at this and let me what I missed?

http://img273.imageshack.us/img273/8994/vncviewer5vn.jpg


The error message that I received when I typed in the ip address for the address is below:


[B]VNC Viewer: 198.222.168.189:Error[/B]
unable to connect to host: The requested address is not valid in its context.(10049)

http://www.redhat.com/archives/rhl-list/2005-July/msg05595.html

I am using FC4. The fix for me was that the default iptables (i think
thats the firewall settings) were preventing incoming VNC connections.
To overcome this in gnome i went to Desktop>System Settings>Server Settings>Services There I stopped iptables - and immediately I was able to connect!

I did stop iptables as qoute above suggested.

You should be trying to connect locally first.

From FC4 try the following:

vncviewer 127.0.0.1:2

the suffix “:2” is the one to match what you put into your /etc/sysconfig/vncserver file.

The gets round iptables, networking etc and so is easier to debug.

If the above works, then the address you are typing in Windows should be:

198.222.168.189:2

And it should work.

If the local connection does not work, look at other security settings like for the X-server. Is “root” allowed to log on remotely? Worth a check.

You should be trying to connect locally first.

From FC4 try the following:

vncviewer 127.0.0.1:2

the suffix “:2” is the one to match what you put into your /etc/sysconfig/vncserver file.

The gets round iptables, networking etc and so is easier to debug.

If the above works, then the address you are typing in Windows should be:

198.222.168.189:2

And it should work.

I will try your suggestion ? Thanks for this advice.

Is “root” allowed to log on remotely? Worth a check.

How can i check that ?

Is the command “vncserver” same as “service vncserver start” ?

You should be trying to connect locally first.

From FC4 try the following:

vncviewer 127.0.0.1:2

the suffix “:2” is the one to match what you put into your /etc/sysconfig/vncserver file.

The gets round iptables, networking etc and so is easier to debug.

It worked.

then the address you are typing in Windows should be:

198.222.168.189:2

When I typed in (198.222.168.189:2), I recieved the same error message that I posted in my previous reply

Note: FC4 box and Win2003 box within the same LAN, the reachability is there (ping each other)

To get VNC working on my FC4 rig I used the GUI method - Desktop - Preferences - Remote Desktop , check the users view and use boxes , uncheck the ’ ask you for confirmation ’ box , set password ,
then - Desktop - Server Settings - Services , tick vncserver box - start - save , (starts at boot up)
There was something else , but cant quite remember - I think it only really worked after I got SAMBA working by setting up a client /share
A word of warning -if you want to use VNC - dont use the ‘New Login’ function under System tools - only one login at a time .

Desktop - Preferences - Remote Desktop , check the users view and use boxes , uncheck the 'ask you for confirmation box , set password ,

I tried this.

Desktop - Server Settings - Services , tick vncserver box - start - save , (starts at boot up)

I tried this as well.

It did not work as well

Any idea ?