BOINC on LTSP directory mounting problem.

I really hate to bug you guys with another BOINC on LTSP question, but this is the only forum that seems to get these problems solved, and I’m at a loss. I am running Fedora Core 5 on my server, with LTSP 4.2. I am able to boot my client disklessly, both graphically and command line, but this is without local apps. When I boot into command line to try to start BOINC locally, I get several errors. The loading seems to go fine until it hits:

Starting syslogd
syslogd: cannot write to remote file handle on192.168.2.254:514

The loading process then continues and comes up with:

Starting sshd…
Could not load host key: /etc/ssh/ssh_host_key
Could not load host key: /etc/ssh/ssh_host_rsa_key
Could not load host key: /etc/ssh/ssh_host_dsa_key
Disabling protocol version 1. Could not load host key
Disabling protocol version 2. Could not load host key
sshd: not hostkeys available – exiting.

After this it then attempts to run the BOINC rc file, which I created using the examples in other threads. Here it also encounters errors:

Starting Boinc
/etc/rc.d/start_boinc: line 15: cd: /home/ws001/boinc: No such file or directory
rm: cannot remove ‘nohup.out’: No such file or directory
rm:cannot remove ‘lockfile’: No such file or directory
nohup: /lib/ version ‘GLIBC_2.4’ not found (required by nohup)
nohup: /lib/ version ‘GLIBC_2.3.4’ not found (required by nohup)
rc.sysinit completed, switching to multi-session mode

tty= /dev/tty1

I have searched the Internet, and found almost nothing related to LTSP for that first error I’m getting. The second error with the sshd, I saw a post on the forums that solved the problem by adjusting the permissions on the workstation directory. I tried this and it did not solve the problem. The last problem is related to the home directory not being mounted. I cannot manually change directories at all at the prompt after boot. I have checked, and the folders are correct and exist on the server, but I just get a no such file or directory error when I try to access them on the client. I have the /home directory added to the exports file and local apps are enabled in lts.conf. Something, somewhere has to be wrong with the mounting, but I just don’t know what it is. I have read many of the LTSP for BOINC related posts, and I just cant seem to get the settings right. I’m still new to Linux as you can probably tell, and I would really appreciate some help, or a point in the right direction. Thanks in advance!

first error = ignore unless you want system log information traffic on your network

ssh, sounds like you’ve not generated the ssh keys on the server, read up on the SSH manual, search on here for a post by MAOJC about ssh and remote access to LTSP nodes.

As for the missing directory mount, check you /opt/ltsp/etc/rc.sysinit - it would appear as if your home directory for the workstation is not being mounted. There could be a few reasons for this. The section in rc.sysinit is labelled “Mount Filesystems” and should have for you something like

mount -t nfs -o nolock ${NFS_SERVER}:/home/${HOSTNAME}  /home/${HOSTNAME}

As you’re aiming to run boinc, remove the IF block and the FI around this part, to make sure that the workstation mounts even if your lts.conf does not have the local_apps flag set.

The other problem could be simply that the dir does not exist in the two places it needs to, the mounted dirs need to exist in both “real” state /home/${hostname} and in /opt/ltsp/home/${hostname}, the ones in the second location should be empty.

You’ll also need to copy the from your servers lib directory into the /opt/ltsp/lib in order to use nohup, I think this bit is described in the guide I wrote.

Good luck :smiley:


Thank you so much for your help! :worship: :hail: :worship: :hail: I have almost got it configured. I fixed the ssh keys and got the directories to mount correctly. The only problem I still can’t solve is with the When the rc file starts on boot, or when I manually start it, it reports:

Starting Boinc
rm: cannot remove ‘nohup.out’: No such file or directory
rm:cannot remove ‘lockfile’: No such file or directory
nohup: /lib/ version ‘GLIBC_2.4’ not found (required by nohup)
nohup: /lib/ version ‘GLIBC_2.3.4’ not found (required by nohup)
------ (same as before, except without the directory error)

If I try to start boinc manually, I get that “Another instance of BOINC is running”. When I went to copy the to the /opt/ltsp/lib, I didn’t find a lib directory there. Creating one and putting didn’t have any effect. I found that there already was a file in the /opt/ltsp/i386/lib directory. If I replace that file with the one from my servers lib directory, I get an error saying: “/bin/bash: error while loading shared libraries: cannot open shared object file: No such file or directory” If I copy the file that links to in my server directory ( to the LTSP lib directory, I get this error: “/bin/bash: error while loading shared libraries: cannot handle TLS data”. I also copied over the other files you suggested in your guide. Placing the file in the /opt/ltsp/i386/usr/lib also had no effect. After messing around with the file from my server for a while, I just put he original back. I also get the GLIBC_2.4 & GLIBC_2.3.4 errors when I use other some commands, such as top. :bsod: What could be causing this? Again, I really really appreciate the help! Thanks!

check the permissions on the files you have copied into the ltsp “tree”. It could just be that the permissions on the files you have copied are denying access.


Sorry for the delayed response, but I have been busy the past month. If anyone is interested, I fixed my problem by copying my servers entire lib directory into the LTSP lib directory, replacing the files. I also did change the permissions on the lib folder. Thank you guys so much! Local apps are working great and ssh and all that is configured. Thank You! :hail:

There is only one problem I need some help with, DNS. I have everything configured, and I can ping Internet IPs, but I cannot ping domains. I’m not exactly sure how to find my ISPs DNS server, as mentioned in your guide. I checked my router, and it lists the IPs of two DNS servers (which I’m guessing are my ISPs). I tried setting them in the dhcpd.conf, but neither worked. I also tried setting a DNS ip in the lts.conf file, which was mentioned in the LTSP setup guide. I was just wondering if anyone knows what I need to do to configure the DNS. Again, thank you guys so much!

re: dns - the best guess without knowing your router is to simply set the DNS in dhcpd.conf to your router i.e., works for me.


I tried setting my router as the DNS server in the dhcpd.conf but that did not work… Just to test, I connected a computer running Windows 2000 to the server, gave it a manual IP address, and set the server as the default gateway and the router as the DNS server. The computer was able to access the Internet fine, and DNS seemed to be working. :confused: So it almost has to be an LTSP setting somewhere. Is there anywhere else that a DNS server needs to be set? I saw somewhere there is an entry for DNS_SERVER in lts.conf. I tried setting that, which also had no effect. Thanks again for the help!

Hi, on my (Debian) setup I have the server’s ltsp side address as the nameserver and it works fine. From a client if I do a cat /etc/resolv.conf it returns:

nameserver # my server’s address

On the server I have /etc/resolv.conf as follows:

nameserver # my internet router
nameserver # one of my ISP’s DNS servers

My apologies, I’m not familiar with Fedora, but I hope this helps. :slight_smile:

That was it!!! Thank you so much! :hail: :hail: :hail: All I had to do was go into the LTSP node’s resolv.conf and set the nameserver IP as my LTSP servers… It’s amazing how simple problems can be :slight_smile: Thanks again!