cpu or mobo?

Main pc died last night :frowning: Went to it and had switched self off, tried to turn back on but nothing…no fans, no beeps…nadda.
Have tested psu and that works, guessing mem works so i think it’s either the cpu or mobo. Green led does light up on mobo though. Anyway of testing without a spare cpu/mobo?


off the top of my head ('cos I’m a bit fikko when I’ve just got in from work) :slight_smile:

make sure the connection for the CPU Fan hasn’t come adrift.

take CPU out and check, then re-seat it (with new paste stuff) if it looks OK

take all peripherals out and see if you get “post” beep

… in any order :stuck_out_tongue:

also make sure CPU fan still works by trying power it up on anougher system as most new systems can detect it working in will not boot if it has failed.

and a fialed mem unit will do same thing not allowing u to boot so may wish test it in anougher unit if u can just rule it out.

Well checked mem and fan (uses a 4pin molex so not connected to mobo) and removed all hardware accept cpu, mem and gfx (even tried without gfx) and get nothing. When trying to start it nothing happens…and i mean nothing, not even the psu fans spin up.
Ordered another mobo today so fingers crossed thats the prob and not the cpu.

A few thing to try

I presume you’ve tried a Cmos reset… try it again but

With main’s power off…

remove the battery… Put Cmos drain jumper to drain position
and short the battery terminal.

Then revert and see if it fires up.

** if Not… PSU check = while no power connections are attached
to motherboard/drives etc etc short the green wire on the atx plug to a black wire.

This will cause the PSU to power up… And its internal fan should spin

If not check the fuse in the plug.

If it does then its a board / cpu issue.

Already tested the psu on another mobo along with the hsf and alls working there. Reset the cmos with and without power connected, haven’t tried the batt out way, will give it a try. Also checked and reseated the cpu…looks fine.

Its the technique that bizzarely brought Neils rig back to life at one of Mojo’s

Was a new one on me when Markone’s m8y did it.

I presume it 100% ensure’s that there is no residue power in the backup
power circuit by shorting the actual batt terminals as well.

Seems it was the mobo…new gigabyte ga-k8ns just arrived, plugged cpu, mem, hsf and psu in and she fired up straight away…phew! :smiley:

phew indeed :thumbsup: