DEP in Vista

Is there anyway of turning off DEP completely in Vista?

It keeps blocking programs I know are safe. Like my mobile phone tools setup package, it’ll close the setup.exe:(

Even editing the settings to allow the program it wont work

This works for xp, don’t know about Vista though but you could try it:
It just adds a line in boot.ini eg (make a copy of boot.ini first)
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Windows XP Professional x64 Edition” noexecute=alwaysoff /fsatdetect
The “=alwaysoff” disables DEP so you could just edit it with notepad.

Turn off the DEP feature in Windows XP SP2
If you need the functionality of the incompatible driver, you can turn off the DEP feature. To do this, follow these steps:

  1. Restart your computer.
  2. During the restart process, press F8.

Note On a computer that is configured to start multiple operating systems, press F8 when the Startup menu appears.
3. Use the arrow keys to select a Safe Mode option, and then press ENTER.
4. Click Start, click Run, type cmd, and then click OK.
5. At the command prompt, type the following, and then press ENTER:
bootcfg /raw “/noexecute=alwaysoff /fastdetect” /id 1
Note If you have multiple start entries or start options, you may have to manually modify the Boot.ini file for your computer. To do this, follow these steps:
a. Click Start, click Run, type sysdm.cpl, and then click OK.
b. On the Advanced tab, under Startup and Recovery, click Settings.
c. In the Startup and Recovery dialog box, click Edit.
d. Change the /noexecute option to the following:
e. On the File menu, click Save, and then click Exit.
f. Click OK two times.
6. Restart your computer.
Hope that works