doc1 version 3.1 and photoshop cs2

hi guys,

this is a long shot at best but i have a customer here who is having problems with doc1 and photoshop.
basicly when photoshop is installed doc1 crashes when its launched… if photoshop is removed it works fine… now before anyone says “upgrade to the latest version of doc1” we cant, long story but we just cant…

now on a second machine used by a different user both doc1 and photoshop play happily together…

anyone got any ideas why doc1 keeps crashing on this machine? any ideas greatfully recived, as this has been in the helldesk Q for months…


Try installing them in different order. sounds like a confilt with one of the dlls

tryed installing both doc1 first and photoshop first but i still get the same proplem sadly,…

i think that this wont get sorted any time…

Google for depends.exe, then run the app that is crashing from within that debugger, you may be able to find the conflict then. Some exes naturally look for dll’s in system32 but if there is a conflict try placing the conflicting one next to the exe. Has been known to work sometimes. One of the most common is the misuse of the zlib.dll compression libs.


You do know that there is a tech support line for DOC1, right?!OpenPage

If you’re getting co-existence problems with DOC1 and another program, they’re the people who will know if it’s possible to do anything about it.



thanks DT i will look into that…

Moz, i allready spoke to group1 and was told that the version of doc1 were using is no longer supported and they had never encountered the problem anyway (personaly i think they just didnt wanna know)

That is odd because they have never been like that in the past. I think it was in 2003 or 2004 that I asked them how many versions they would be supporting as time went on, and they said they had been “very committed to long-term support” and were supporting right back to version 2.xx and had been doing so for 6 years (from the time of writing).

Obviously they recommend that you stay relatively up to date, but I am surprised to hear that they have discontinued support for 3.1. I would have expected them to phase out version 2 but keep 3.x running for a while. As it is, DOC1 is not a cheap product - though I saw an article that sales are down, so maybe they’re cutting costs.

Back to the original problem, have you tried logging into the PC where it doesn’t work, but using the user ID from the working PC (assuming you’re on a network)? What user ID are you installing each application under, i.e. what privileges do the IDs have? Failing that is it possible to use a different PC or a different ID just for DOC1? We do this as we have a limited number of licences.