Exchange server question

I’ve been battling with this for a few minutes :wink:

Domain has all mail delivered to a linux box, doing a nice job of spam filtering. This is using IMAP for mail collection by clients…

I’ve got a Windows Small Business Server,, some uses want to use the exchange mailbox - all users want to use the sharepoint site.

So email is all arriving on my linux box, and if the user wants exchange I’m forwarding the mail to, this part all works fine. Users on the exchange box can send email and the primary address space is set to

My problem is that the exchange server insists on sending mail to itself, not touching the external smtp settings regardless of whether I set it to not be the authoritive mail machine.

So to clarify, it who is an exhange user mails to anything it is not going through the external smtp connector that I’ve specified.

What have I missed ?


Exchange will always try and deliver the email locally first. If the domain is managed by that server and it doesn’t find the address on the server it will toss it.

What you need is the * option which delivers all email not found on the local server to a remote host. Why would people want the linux box anyway? Why not enable IMAP on the exchange box?

I think your best option would be to create a sub domain like for exchange and the main domain on linux and then forward the main domain to Then set the reply to address as the on exchange or you can set the exchange server to send through the Linux box as a relay and do header re-writing.

Basically you would have to use a different domain on the exchange server as far as I know.

office politics as to why the linux box must stay :frowning:

Your description is exactly what I tried, but exchange recognises it, so I think my only option is to use (primary domain) on the linux server, and then cheat and use on the exchange server with the send address as (which I’ve done and it works).

Just need to get sign off to do it this way. The tickbox in policies that is titled “This Exchange Organization is responsible for all mail delivery to this address” doesn’t seem to work. According to MSDN this should mean that it will never try to do local delivery, but it does :sigh:

Cheers Jugster :slight_smile:


M$ never works as advertised.

shhh, and there you have hit the nail on the head on the office politics bit of why we must have a linux machine handling the machine.