memory sticks

i had a 4gig memory stick for xmas but i put a film and a game on it to transfer to someones pc well it won’t do it…lol
and i can’t remove said film or game from the stick or put anything on the damn thing keep getting this message "data error (cyclic redundancy check )
any ideas chaps ? :slight_smile:
many thanks

I assume you mean a USB flash drive as opposed to the Sony memory stick.

One thing to note is when you copy files to it, give it time to finish writing. Don’t just yank it out as soon as the windows dialogs appear to complete. If the stick has a light on it, make sure it’s not showing activity.

From what you say, it might be worth formatting it just to clear it out and start fresh. After that, if it keeps happening, then possibly you might have a duff stick.

yes sorry it’s a USB flash drive tried formatting it wouldn’t format :slight_smile: but if it’s a duff stick surely nothing would have gone on it in the first place!
i know theres nothing wrong with the USB ports on my lappy i got 4 and have tried the stick in all of em and the other halfs pc still not good :frowning: theres no name on the stick or i’d have looked online to see if there were any write ups on it

Wrap it in plastic and put it in the freezer. Chill for 2 hours and then try & reformat it when back at room temperature. Never done it myself, but a friend said they had tried and it worked. Might work for you, but I can’t guarantee anything.

will give it a go nothing to lose :slight_smile:

well that didn’t work :frowning: thats 2 i got now thats knackered …lol

You sure it doesn’t have a write/delete protection switch on the side?

can’t see anything on it

Try the HP USB Disk Storage Format Tool

got that tool but it tells me it’s write protected but theres no switch or anything to turn it off :frowning:

Hmmm. Have you tried …

Control panel > Administrative Tools > Computer management.
Left click on Disk Management.
In the right hand pane, you should see a graphical representation of your USB stick.
Prob. will have a file system type of RAW.

Right click on this drive, then select ‘Delete Partition’. After you have deleted the partition, right click on the drive again, then select ‘New partition’. Follow the prompts, then select ‘Primary partition’, then type ‘FAT32’. Right-click again, then format.

If it’s greyed out in disk management …I’m stuck there :frowning: I know chkdsk doesn’t work, though Fdisk might, though I’ve never tried it.

hmmmm it’s grayed out in disk management :frowning:

Sounds fubarred to me. Looks like a trip to the shops may in order m8. :frowning:

yeah was thinking the same thats 2 4gigs i got that don’t work :frowning:

Thats me out of ideas. Soz.

I found tho’ that sticks don’t like being formatted as NTFS btw - seems to kill em’ - not that applies. :frowning:

ok thanks for all your help guys guess i’ll have to start saving the the pennies for a new one :slight_smile:

ill go out on a whim here and ask where they bought off ebay for cheap ?

they could be fake… if they have nothing on them… writing wise…

find out where they came from :wink:

no they wasn’t bought from ebay and i have a film and a small game on the one i had for xmas not sure where it was bought from i only know it wasn’t from ebay :slight_smile:

Had a look around on Office Depots web site and found this for $24.99.

thanks P51 nice site :slight_smile: