need some help, no display

a couple of months ago, my i5-2500k rig stopped displaying. It would boot, fans, lights, hdds, all came on, but the monitor would shut off, saying no signal. I tested my monitors and cables on my laptop and I got a display. Had a few other issues at the same time, so ended up replacing the motherboard (twice), the cpu (the original had an odd mark on the bottom contacts), replaced/upgraded the ram. I did try replacing the graphics with an old card I had, same issue. Even tried swapping out the PSU with an old one I had laying around, no change. I feel like Ive swapped out everything I could, but am still getting the exact same results…any ideas? This has been plaguing me for months.

Plus, if I get my rig up and running again, I plan on getting back into crunching… :slight_smile:

I know you said you tried it on the laptop and got a display, but it still sounds like a monitor issue, have you tried other monitors with the rig?

(Assuming this is a Windows box, and that your laptop is also running Windows) Can you use your laptop to “make a Remote Desktop Connection” to your i5 machine, and (by rignt-clicking the desktop) look at its display settings? Maybe its an analog vs digital setting.

I have tried both my monitors…and I will have to try the Remote Desktop Connection…I forgot all about that.

I tried again with the monitors, and even ran and HDMI to my TV, the TV is reporting NO SIGNAL. The odd thing, maybe, is that I even tried the integrated graphics, both the DVI and the HDMI outputs on my new motherboard, but no signal.

Also, I dont know if I have Remote Desktop enabled on my tower (Win7) or else my laptop (Vista) is having problems seeing it.

Might be a power issue. Try disconnecting dvds, additional drives, usb conneted devices etc and start up with bare minimum connections (keyboard, mouse & monitor). Does it boot up ok in safe mode?

I have a modular PSU, was thinking maybe the PCI-E cables or ports maybe bad…as soon as i hit the power button, the monitors shut off, saying No Signal. I cant access BIOS, and tried the Remote Connect, but cant see it on my network. Right now the only things plugged in are the motherboard (24 and 8 pin connectors), my SSD boot drive, the HSF, and a couple of case fans. Its cool enough, I’ll disconnect some of the case fans so that the power draw is as minimal as possible. Thanks for the ideas so far.

The issue is DVI or VGA. Try an adapter to flip the signal.

Do you get error code beeps when you boot up without any ram in their slots? If so, try 1 stick at a time in all the slots


Very common issue with DDR2/3 DIMMs.

after stepping away from the PC for awhile, got back to work on trying to fix my issue. Ended up being a bad PSU. Even though I had swapped out the PSU with a known good one and I used a PSU tester on both. But with my new kit, finally got a diagnostic LED to light up, it was the CPU. Apparently some others had the same issue, purchased a new PSU and it fired up right away. I feel silly for just not replacing it earlier.