New storage box


#1

No, my shopping isn’t done yet! I’ve kinda decided to not have mass local storage on my new box after all, and instead run another networked box instead. Ebuyer currently has a HP ProLiant Gen8 microserver at £115 after cashback. Comes with 4GB ECC ram, no HD, no OS. I have an earlier one as my backup box and like the build, so got this one thinking it’ll be same but newer and better. Well, it might be, but this time around it is a true server, full of management stuff I don’t understand and it takes forever to boot before it even starts loading the OS. Plus getting any info out of HP without a support account is like talking to a pet rock. The old one ran WHS2011 but this time around I think I’ll give FreeNAS or similar another attempt.

So far I’ve done a non-activated install of Win10 just to test it out. There’s a support DVD I’m downloading after finding the link indirectly but HP’s servers are really slow so it wont be done before morning. Processor is a dual core Ivy Bridge Celeron at 2.3GHz. Seems to be ok but lacking AVX instructions so that will hamper any thoughts of crunching with it. Ram I’m not sure about. 4GB is enough to get along with, but it is single channel. As it is HP stuff, the server can validate and report on errors from it, which it apparently wont do if you use 3rd party ECC ram. And non-ECC is apparently not an option.


#2

I have a freenas server plus 2008/2012 Windows servers. I like the NAS - simple and remote use is easy.


#3

The download of the driver/update DVD failed overnight. I started it again before leaving for work so wont know what state that is in until I get home. Separately I did try downloading it at work. Using a web browser, at least I was getting a much higher transfer than I was at home, but again it terminated early. Maybe it doesn’t like browser ftp clients? I downloaded a dedicated ftp client and tried again. It worked and I verified its md5. The weird thing is, during download the speed was much lower than it was in browser. I don’t know if there is some regulation in the software or perhaps something else was going on? There seemed to be a slow ramp effect, going from near zero up to about 50Mbps then dropping near zero again. Repeat, a lot. Don’t know if it is the software, the work network, the internet in general or on HP’s end, but I’ve not seen that effect before.

I’m debating if it is worth trying iSCSI as opposed to regular Windows shares, since in the past I found the latter a real pain to set up permissions for and never really got working. But if I run iSCSI I’ll be using NTFS. I was debating giving ZFS a try which means I’d have to deal with setting up Windows shares again…

Note I only need one PC to talk to this, so sharing on a network isn’t needed at all.


#4

Having a serious love-hate thing going on now.

I can’t do anything with the un-activated Win10 install. The HP stuff wont run on it saying I’m not an admin when I damn well am. Tried a few things, including turning off UAC (which I do as standard anyway), and running the software as admin on top of my account being admin. Nope.

Fine. Installed un-activated Win7. This is better. HP software ran and did various updates. But nowhere could I find Win7 drivers for the two network ports. Not on the DVD image, not online.

I give up… let’s not faff around with Windows. This is a storage box, so let’s try FreeNAS again. Except I can’t. The current version is 64-bit only, which is fine, but in the process they upped the minimum ram to 8GB. I have half that… ram compatibility is a nightmare, and get different answers depending on where I look. The included module doesn’t match anything on the QuickSpecs sheet, doesn’t match anything on HP’s website configurator. In the end I found the same part as already in there on ebay, from someone selling as they upgraded same to 2x8. That’ll do nicely, and at a lower cost too. So I wont be finishing this install any time soon.

Until then, I decided to tinker with the old model. That boots so fast in comparison, even with the cheapo Atom-class AMD processor in it.


#5

Box has now got 8GB of ram and enough for FreeNAS. And it is still as annoying and unintuitive as it was the last time I tried it. Like asking me how big a share I want to make, without telling me how much space I had available for said share. And I still can’t find an easy way to set up Windows shares. It looks like it has plenty of options if you want to stick it on a corporate network, but not if you just have a random bunch of users you want to manually set up.

On my tinkering drive I managed to get Win7 to a runnable state now. Found an article elsewhere that basically showed the drivers are only available for server OSes, but they do work on the equivalent user OS. e.g. Server 2008 R2 drivers work fine on Win7, so now I can use the rear USB ports and network connections.

My old server had WHS 2011 on it, but it isn’t available any more, and in any case, support ends next year anyway. If I stick with Windows since that just works, I’d really want to go for 7, if I can still find it. Win10 is going to be pain in this role for multiple reasons, and I’m not sure about 8 either. The lack of any further consumer server OS from MS doesn’t help, as the full blown ones are silly.