Problems with WoW cataclysm performance

So just rebuilt my PC with win 7 ultimate x64 and a new graphics/sound card. All is well except WoW seems painfully slow. In fact it’s running between 9-14 FPS. The odd thing is it doesn’t seem to matter what I do with the settings it stays the same. If I run at full native res on the 30" (2560x1600) I get the same performance as 1680x1050. Similarly if I set it on ultra level it’s the same frame rate as when set on low. Obviously I can see the detail changes applying but nothing seems to impact the frame rate. It’s odd because my old 9600GT coped way better (admittedly that was WotLK and on vista). I’ve also tried the recommended settings, windowed, DX9 and DX11 still no differences. The nVidia control panel thing is set to let the 3D app decide but I’ve also tried overriding and setting to performance. Still have the same problem.

3D mark appeared to run ok and suggest the PC was ok:

Any ideas?


Win7 x64 ultimate SP1
Gigabyte Technology Co., Ltd. EP45-UD3LR
8GB RAM OCZ 7 @ 400 MHz
GTX560ti - running HP 30" screen & Samsung 19"
GeForce 6200 - Samsung 19"
Asus Xonar Xense sound
4x 1,000GB Hitachi HUA721010KLA330 ATA HDD (AHCI)

ok found the problem. It’s CTmod. Turn it off and can run in ultra settings full screen at 70fps

What’s CTMod?
/edit no probs, googled it…