VNCing to Linux machines

Is there a way to force vncserver to serve the currently logged in user’s session to a vnc client? I have vnc working with no problem, but want to connect to the running desktop.

I want to check the status of Linux crunchers on a LAN remotely.

there is a way, can’t for the life of me remember how though…
tried connecting your client to (for example) or :1 or possibly even :0.0


Not sure what you mean , but to check on my remote Ubuntu crunchers , I enable remote desktop by going to -System/Preferences/Remote Desktop and tick both buttons in the 'sharing ’ section then untick the ‘confirm each connection’ button (important) and assign a password . I haven’t used SUSE for while but I remember it was a bit of a bugger to set up.

More thoughts – I normally use Boincview or Fahmon to monitor the work on the remote crunchers and only use VNC for remedial connections . you can do quite a lot with Boincview - attach, detach, connect, enable/disable work etc. as far as I know the original site has gone but someone (Uncle Fungus??) has the source code and is working on it . there are still some of the old releases being hosted and work well enough for me .

Why not just unc path to the stats file for reading?

I finally figured this out. This is on openSUSE 11.1. It only took about 8 hours of Googling first on topics then on subsequent error messages over and over until things were narrowed down. Every last thing has to be specified as allowed through the firewall: the VNC server, VNC client and the ports. Some of which is hidden in Advanced options. Remote administration has to be enabled, allow others to see your desktop, allow others to control your desktop, require a password, then use an alternative port has to be ticked - even when using the supplied default port number and the password is left blank. All of this is done with GUI tools. This does not even start the VNC server though. Another GUI tool has to be invoked from the command line to set final preferences. The server will then start and persist through a reboot. The real kicker though is that nothing will work unless autologin (the default) is disabled, another buried Advanced setting. This is not mentioned anywhere and led to more Googling on error messages. It’s especially frustrating since it’s comparatively easy to get a new login session via VNC. Connecting to the currently running desktop, though, is a bear.

Phew. Done now though. My Linux crunchers can go to the cool of the basement for the summer.