WD2500JB showing as 20gb capacity

ok, let’s get the laffs and shrugs and :eek: out of the way first :stuck_out_tongue:

I am STILL using Win 98se :nod:

I have a Western Digital 80gb drive that shows up as 80gb, or near as, high 70’s and almost full.

I have a new 250gb drive but it only fdisk’s and shows up under Explorer as 20gb :frowning:

Tech Spec
WD2500JB - 00GVC0
Current Jumper setting for IDE 1, slave.

Now somebody told me a while ago that this is an OS limit, and that does not surprise me. BUT… they also told me about another jumper, an LDA or LDM or something that should force the OS to recognise the increase or pack the data differently (FAT16/32)???

So, anybody who fancies a challenge, I lay it down… there is only one bank of settings for jumpers (10 pins) and I cannot find anything information about this ‘fix’.

Anybody up to it?


LBA and it can be st in the BIOS on most modern computers.
(Logical Block Addressing) If I remember correctly.

Use fdisk to enable large disk support as well.

Considering your dated OS choice Bob, see here:


I believe this may also be limited though - it certainly threw a major hissy fit when I tried to use it on a 300Gb drive.

I will check this out, thanks.

Set this as standard mate, thanks

I did find that but discarded because of the highlighted sections.

When you use Fdisk.exe to partition a hard disk that is larger than 64 GB (64 gigabytes, or 68,719,476,736 bytes) in size, Fdisk does not report the correct size of the hard disk.
Works fine on my 80gb hd without this fix

The size that Fdisk reports is the full size of the hard disk minus 64 GB. For example, if the physical drive is 70.3 GB (75,484,122,112 bytes) in size, Fdisk reports the drive as being 6.3 GB (6,764,579,840 bytes) in size.

Fdisk uses some 16-bit values internally to calculate the size of the drive. Some of these variables overflow when the drive size is equal to or larger than 64 GB.

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.
Half and half and did not want to lose the half that is working :wink:

Every straw is getting close to breaking the camels back… when is the next OS due? I may downgrade to XP when it is released :eek:

BIOS information

Type: Auto
Cyclinder: 38309
Heads: 16
Write Compression: 10325
Sectors: 255
Maximum Capacity: 80.0 Gb
LBA Mode: On
Block Mode: On
Fast Programmed I/O Modes: 4
32 Bit Trnasfer Mode: On


Type: Auto
Write Compression:
Maximum Capacity: 250.1 Gb
LBA Mode: On
Block Mode: On
Fast Programmed I/O Modes: 4
32 Bit Trnasfer Mode: On

Cylinders to Sector entries are blank on new drive.

Any idea on settings, other than auto? numbers 1-48 then auto and some others.

Silly question Bob - do you have them on the same IDE channel or an optical on with the 250Gb?

WD drives have a ‘Master - Single Drive only’ jumper setting (default) that causes that kind of oddity when another drive is introduced on to the same cable.

Sorry, I didn’t make that clear in the original post did I :doh:

IDE1 - 80gb (I think set at something, I presumed Master as it was the only one on there but I should check that first, lol)
IDE1 - 250gb set as slave
IDE2 - Toshiba CDR set as Master
IDE2 - TDK CDR/W set as Slave

I will get back to you with some more info in about 30-40mins… have to nip out first.

Sorted mate, was exactly that :rotate:

Thanks to all for their help and suggestions with this :wave: