Can anyone help me?


I am at my wit’s end. I have been working on this for three weeks, and I am so frustrated! :wall: :bsod: :cry:

A year and a half ago, my friend helped me set up a Linux Mandriva server for email, web pages, file storage, and mysql. While I am computer literate with Windows, I am new to Linux. My friend set me up with Webmin to manage the server, and that was how I did it for a year and a half.

Unfortunately, the motherboard blew a capacitor, and I don’t have the know-how to repair that. The motherboard was very old (, and I really don’t want to pay $150.00 to replace it. I tried to boot the hard drive in the new system, but it freezes on the splash screen with a kernel panic. I tried getting help on the Mandriva forums, but they were impatient with me and rather rude (not to mention a little overwhelming). My friend that helped me set it up does not have time to help me again, so I am on my own.

So, I have a new system with a new hard drive, on which I have installed Mandriva Power Pack 2010. I copied over some of the settings (only the ones regarding my host name and domain). All of the services are working, but my server will not resolve to my domain name. My server is also refusing email connection. I have managed to ping my server successfully using a command prompt.

I am very computer literate with Windows software and basic hardware, but my weak areas include programming and networking (although I am currently attending college for programming). These two areas are quite hazy for me. I am also a bit new to Linux, though I am learning a lot from this experience.

I still have the old server hard drive (it has Mandriva 2008) which is completely functional; it just doesn’t want to boot. We have tried editing the fstab files and the menu.lst files, but it will not move past a kernel panic. I do not have a Live CD, and the company does not sell them anymore. I can fully access the drive as a secondary drive only.

Could someone please please help me? Please? I tried on the Mandriva forums, but they were impatient with me and a little rude. I have posted this in so many other forums, but no one has replied (except to confirm what a complicated problem I have). I don’t know where else to go! :sigh:

Firstly, welcome to TPR :wave:

Reading the above it seems that you have a working system with most of the things you want to run up and working :slight_smile: Am I right in thinking that your only (or main) issues are

my server will not resolve to my domain name. My server is also refusing email connection.

Could you expand on these points? I’m pretty certain the 2nd point is dependant on the first… many e-mail server configs will not route mail if domain name lookups etc aren’t functioning.

Can you compare the /etc/hosts on both hard disks ? It may be as simple as adding in the domain name next to the relevant entry in the hosts file. Unless of course you are reffering to DNS lookups, in which case we might need more to go on.

Happy to help :slight_smile:

Thanks for the welcome!!! I love your “Team Phoenix Rising” name. And I absolutely adore all these smileys! :thumbsup:

<== has a thing for phoenixes

Firstly, thank you so much for responding!!! I posted this on the official Linux forums and received no helpful answer. And the Mandriva forum was just an experience I would like to forget. :uhh:

OK, when I go to my forums, the page displays as completely blank…no writing, no error messages…just blank. Like this:

The two /etc/hosts files were different, but I corrected it. There is no change, though…are there any other files that I should change?

a 500 error like that one is normally down to file permissions.

goto the folder where you have your forum files and do “ls -altr” and give us a post of that line.
It’s going to be either a chmod operation you need to do, or a chown to allow the web server to read/operate the files.


Output is:

[root@Krimson cartbeforethehorseforums]# ls -altr                                        
total 468                                                                                
-rwxr-xr-x  1 apache apache  1801 2009-11-16 12:10 faq.php*
-rwxr-xr-x  1 apache apache  6004 2009-11-16 12:10 cron.php*
-rwxr-xr-x  1 apache apache 13966 2009-11-16 12:10 viewonline.php*
-rwxr-xr-x  1 apache apache  9528 2009-11-16 12:10 ucp.php*
-rwxr-xr-x  1 apache apache 24321 2009-11-16 12:10 mcp.php*
drwxr-xr-x  3 apache apache  4096 2009-11-16 12:10 language/
drwxr-xr-x  2 apache apache  4096 2009-11-16 12:10 docs/
drwxr-xr-x  4 apache apache  4096 2009-11-16 12:10 adm/
-rwxr-xr-x  1 apache apache 28480 2009-11-16 12:10 viewforum.php*
-rwxr-xr-x  1 apache apache   388 2010-01-26 12:21 config.php*
-rwxr-xr-x  1 apache apache 68023 2010-03-05 20:45 viewtopic.php*
-rwxr-xr-x  1 apache apache  8176 2010-03-05 20:45 style.php*
-rwxr-xr-x  1 apache apache 43702 2010-03-05 20:45 search.php*
-rwxr-xr-x  1 apache apache  6094 2010-03-05 20:45 report.php*
-rwxr-xr-x  1 apache apache 59593 2010-03-05 20:45 posting.php*
-rwxr-xr-x  1 apache apache 62281 2010-03-05 20:45 memberlist.php*
-rwxr-xr-x  1 apache apache   435 2010-03-05 20:45 .htaccess*
-rwxr-xr-x  1 apache apache 38004 2010-03-05 20:45 feed.php*
-rwxr-xr-x  1 apache apache  6351 2010-03-05 20:45 common.php*
drwxr-xr-x  2 apache apache  4096 2010-03-25 13:08 store/
drwxr-xr-x  2 apache apache  4096 2010-03-25 13:14 download/
-rwxr-xr-x  1 apache apache  4952 2010-03-25 14:11 index.php*
drwxr-xr-x 14 apache apache  4096 2010-03-25 14:14 includes/
drwxr-xr-x  2 apache apache  4096 2010-03-25 14:19 js/
drwxr-xr-x  5 apache apache  4096 2010-03-31 11:45 styles/
drwxr-xr-x 13 apache apache  4096 2010-03-31 13:53 ./
drwxr-xr-x  7 apache apache  4096 2010-04-09 17:25 images/
drwxr-xr-x  2 apache apache  4096 2010-06-27 17:19 files/
drwxr-xr-x  2 apache apache 12288 2010-07-10 10:01 cache/
drwxr-xr-x  6 apache apache  4096 2010-08-04 13:57 ../

Hiya ladykrimson :wave: I’m thick as a brick when it comes to Linux, but what I do know is this … if the Linux guys here can’t fix your problem we may as well all go back to living in caves :smiley:

… sometimes I miss my old cave, but no way am I going back to it :tiphat:

Oh! I got the index page to show up.

Crikey, all I did was post hello and now something works :lol:

pats himself on back

You know, I had an idea this morning. I still have my Mandriva 2008 disk. What if I installed 2008 on the new disk? Would it be easier to migrate settings and such if the operating systems are the same?

well, ownership of the files is fine, so it’s probably a config setting in the config.php causing it to fail. As the config.php just declares php variables, that doesn’t give a 500 error.

You’ve got a lot closer now than the original post, you have the domain resolving fine and the web server is operational, I think you’ve yet to configure email though - that’s probably a port issue on the firewall.


I rechecked my firewall settings, and they are all set to what they should be set to. POP3 is set to port 110, SMTP is set to port 25, HTTP is set to port 80…

A friend of mine mentioned something about interpreting. My forums still come up as a blank page. Is there a service that needs to interpret the data?

Is MySQL working? And have we established that PHP is working?

What happens if you create a file (call it test.php) for example with the following in


and then browse to it in the web browser?
Obviously it’ll need to be in the web server folder.

Instead of me copy-pasting the results, this is the link (to make it easier :slight_smile: )

How can I find out if MySQL is working?

if you are on the command line, either type “ps aux” which is kinda an equivalent to taks manager.

Or a better method is to try to login directly with mysql -u{username} -p (assuming a password is set, which is should be:))

I’m just about the scan your IP for open ports, you might get a few firewall messages depending on your firewall :smiley:


my turn to double post, I’m going to take a stab that youve not got mysql, and that’s why your forums aren’t running. The mysql env settings should appear in the phpinfo() page and dont’ appear to :frowning:

nmap results are in, port25 and 110 are closed, are you port forwarding your router or do you have the machine in the DMZ and using hte Mandriva iptables? 21, your FTP server is open though.


[QUOTE=DoubleTop;455234]nmap results are in, port25 and 110 are closed, are you port forwarding your router or do you have the machine in the DMZ and using hte Mandriva iptables? 21, your FTP server is open though.


Wait…my ports are close? :eek:

Oh, Comcast, those :censored: :censored: . They did it to me again. They closed my 110 and 25 before…I had to call them and complain a lot, and they opened them.

I don’t have mysql??? Hmmm, that is interesting. In my Webmin window it shows up as running…Ugh…OK, how do I install mysql? Through the linux package updater?

it might be that mysql was installed after php, and therefore the use flags when compiling wouldn’t have had mysql.

I’m not 100% sure on how to do a recompile on Mandriva, a swift :google: found this though

You could just be missing these two
urpmi php-mysql
urpmi mod_php


OK, so I also have a mystery. Port 110 is supposedly closed (I’ve run three tests myself to confirm), yet I still receive email from my Comcast account, which is currently set to Port 110. How is that possible?

Thank you again for all of your help! I appreciate it immensely!